Hard drives not detected

10 11868

After having my banana pi for four days and being very happy with it I tried to connect a hard drive to it today without success.

This is what I've tried so far:

- Four different hard drives (OCZ Vertex 2 40gb, OCZ Vertex 2 60gb, Kingston Hyper X 120gb and Toshiba 2.5 MQ01ABF050 500gb)
- The combined 5V and sata cable that came with my banana pi.
- I've supplied power to the banana pi through 5.1V/2.1A and through a powered usb hub (I used the correct plug and not the OTG).
- I've hooked the hard drives up to a Seasonic X series 850W PSU and tried it with two different sata cables.
- I've tried four different images (Lubuntu_1404_For_BananaPi_v3_1_1, bananian-1409, Raspbian_For_BananaPi_v3_1 and ArchLinux_For_BananaPi_v2_0)

This message will show up in dmesg no matter if I have hard drive connected to it or not:

[    1.572571] SATA AHCI Phy Power Failed!!
[    1.667535] SATA AHCI Phy Calibration Failed!!
[    1.681142] sw_ahci sw_ahci.0: controller can't do PMP, turning off CAP_PMP
[    1.692380] sw_ahci sw_ahci.0: forcing PORTS_IMPL to 0x1
[    1.705145] sw_ahci sw_ahci.0: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode
[    1.720042] sw_ahci sw_ahci.0: flags: ncq sntf pm led clo only pio slum part ccc
[    1.730797] scsi0 : sw_ahci_platform
[    1.741630] ata1: SATA max UDMA/133 mmio [mem 0x01c18000-0x01c18fff] port 0x100 irq 88
[    1.753466] Fixed MDIO Bus: probed
[    2.103256] ata1: SATA link down (SStatus 0 SControl 300)

It's like the banana pi doesn't even recognize that I have connected a drive to it.

Have I missed something completely obvious or is the SATA port dead?

On my Banana Pi with an SSD connected at boot time (right now running Bananian 14.09) it reads:
  1. root@bananas ~ # dmesg | egrep -i "sata|ahci"
  2. [    1.568892] sw_ahci sw_ahci.0: controller can't do PMP, turning off CAP_PMP
  3. [    1.580140] sw_ahci sw_ahci.0: forcing PORTS_IMPL to 0x1
  4. [    1.592896] sw_ahci sw_ahci.0: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode
  5. [    1.607795] sw_ahci sw_ahci.0: flags: ncq sntf pm led clo only pio slum part ccc
  6. [    1.618545] scsi0 : sw_ahci_platform
  7. [    1.629340] ata1: SATA max UDMA/133 mmio [mem 0x01c18000-0x01c18fff] port 0x100 irq 88
  8. [    2.109811] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Copy the Code
When you try it with the Toshiba can you hear the drive spinning up (you said you use the combined SATA/power cable but also an ATX PSU? Most ATX PSUs won't provide power on their rails unless there is a specific and rather high load on 5V -- sometimes it's required to have 1A or above).

BTW: According to the SATA specs the internal SATA connector is specified for just 50 matings (and I've had the case personally that cheap cables/connectors didn't survive just 10)

As for this msg could be a power supply issue:
[    1.572571] SATA AHCI Phy Power Failed!!
You should try connecting the drive directly to Banana, without any external psu.
I think 5V 2.1A should be enough to handle a sata disk.
Sata line should be one like this, because of polarity (be careful with that):
http://forum.lemaker.org/thread- ... _for_banana_pi.html

Hello jens_fm!

Try to power your banana pi with 5V 2A power supply.

I have a power supply like yours, and my banana pi don't do anything. When a buy the right power supply for Bpi it will booted up and recognize the HDD too.

Hello again,

I bought a new PSU today so now I've tried to power the bpi with three different PSU's (5.1V 2.1A, 5V 2A, 5V 1.2A).

When I connect the 5V 1.2A PSU straight to the bpi I get a "knocking" sound from the drive which could be from that it doesn't get enough power. With the other two PSUs there's some sound when plugging the power in and there's a whining noise which I guess is the drive spinning down from pulling the plug.

I've put a usb voltage and current tester in between the PSU and usb-cable and got this result.

Bpi only   5V 0.2A
Bpi hdd   5V 0.5A

I also tried to connect my cellphone and it used 5V 1.0A charging my phone so it seems as it's accurate.
The power requirement for the HDD at idle is 0.3A according to toms hardware which should account for the extra 0.3A when connected to the bpi.

I'm still however getting the same message in /var/log/dmesg at boot.

My SATA line is the same as the first post in the link from actkk2000.

What else is there that I can do to try to get my bpi working with a harddrive?

With a traditional hard drive where you can sense whether it spins up or not you can check whether the power supplied to the drive is sufficient or not (with 3.5" drives the situation is different due to 2 different voltages to be supplied to the drive).

I doubt your measuring between PSU and cable is reliable enough since long/thin cables act like a resistor and the ferrite bead(FB3) betwen pwr-in and the SATA power connector on the board might further decrease the voltage available to the drive. It might help if you read the values the AXP209 PMU supplies via ICU out -- you get current (mA) and voltage (V) with the following shell code:
  1. awk '{printf ("%0.1f",$1/1000); }' </sys/devices/platform/sunxi-i2c.0/i2c-0/0-0034/axp20-supplyer.28/power_supply/ac/current_now
  2. awk '{printf ("%0.2f",$1/1000000); }' </sys/devices/platform/sunxi-i2c.0/i2c-0/0-0034/axp20-supplyer.28/power_supply/ac/voltage_now
Copy the Code
If it's not insufficient power and you already tried different cables maybe the SATA connector on the Banana Pi broke (I try to absolutely reduce the count of SATA connector/cable matings on cheap devices)

Hi tkaiser,

This is what I got when running your shell code with traditional hdd connected.

root@bananapi ~ # awk '{printf ("%0.1f",$1/1000); }' </sys/devices/platform/sunxi-i2c.0/i2c-0/0-0034/axp20-supplyer.28/power_supply/ac/current_now
root@bananapi ~ # awk '{printf ("%0.2f",$1/1000000); }' </sys/devices/platform/sunxi-i2c.0/i2c-0/0-0034/axp20-supplyer.28/power_supply/ac/voltage_now

When powering the bpi through psu I've only tried the one sata line I got with my order. The other cables I tried where when my ATX psu were involved.


Hmm.. current/voltage looks good. When you can verify that your HDD spins up or in case you have a second system where you can read out the SMART values of your drives for an increased power cycle count (SMART attribute 12) then I would suspect the SATA connector on the Banana Pi is broken.

I used smart utility for Mac OS X and got these values from my Toshiba 2.5 MQ01ABF050 500gb

ID# 12
Attribute Name Power Cycle Count
Flag 0x0032
Value 100
Worst 100
Threshold 0
Type Old age
Updated Always
Failed Never
Raw Value 5

Edited by nexusnet at Sun Mar 1, 2015 20:22

I am having a similar problem with both of my Banana Pi units.

For context, my Ban Pro devices detect and mount USB HDDs. My RasPi B+ and v2B+ devices with powered Raspiado USB add-on boards also detect and mount these drives. (I don't attempt to run USB-powered HDDs on Ras Pi units bc those are known to be problematic - they mount but throw errors and fail on read/write).

With the Ban Pi devices, however, I have tried both a USB HDD (Western Digital) and USB thumb drive (Sandisk). Both storage devices are found and mounted on my Mac and other "pi" units. Neither is detected or mounted on either of my Ban Pi v1. Curiously running lsusb as root shows both of these devices. Thus they are being detected at the USB controller. Also the "lights" on both devices come on normally. I've put a PiHut powered USB hub between the Ban Pi and drives - working on the same theory that drives using the Raspiado boards on the Ras Pi B+ and v2B+ units). Same results.

I suspect this is either a power or driver problem. I have used the Pi Hut powered USB hub to run drives on Ras Pi machines before, so I'm puzzled. Also I've used this drive before enough - and checked the format on my Mac - so I'm looking to the Ban Pi v1 as opposed to the HDD. The USB stick, though, baffles me. Even if that HDD were too much for the Ban Pi USB, the thumb drive should work. I've used in on Pi's as a go-to temp storage utility drive. My OS is Raspbian downloaded from the Ban Pi downloads in the last few days. I performed apt-get update and upgrade on both Ban Pi units before starting on my config work today.

Can anyone suggest a solution or things I should look at next??


Edit since initial post: I have checked dmesg by plugging in the USB thumb drive after a clean reboot, while logged in. No errors, although the last message says "usb 2-1: new high-speed usb device num er 2 using ehci-platform". When I pull the thumb, I see "usb-2-1: usb disconnect, device number 2". When I plug in the HDD, I see "usb 2-1: new high-speed usb device num er 3 using ehci-platform". Messages confirm what I found earlier: usb subsystem sees the devices - and appear to do so without errors. Am I seeing a driver problem caused by my update/upgrade?

Second update: no device is being created in /dev when either device is inserted.

Third update: I swapped a Raspiado USB add on card over to one of my Ban Pi units. Raspiado is externally powered by a reliable bench supply that displays volts, amps, watts - same Raspiado and bench supply used to test these drives on a Ras Pi B+ where both mounted. Same result as above - no device created, no drive mounted, nothing showing up above the USB level. Same device messages in dmesg.

You have to log in before you can reply Login | Sign Up

Points Rules