Bananian

Samba with Mac Os X

3 2425
koev36  
Hi,

this has been reported a lot with QNAP Nas systems. When I copy files via samba from a Mac os x client with the Finder to a samba share the machine tells me at 99% that the file is in use an cannot be copied.

This never happened with Openelec (raspberry pi) or any other linux distro.

Any one else experiencing this

****
using cifs://<host> doesn't work I already tried that. same error
tkaiser  
Unless you aren't using Samba 4.2 or above and stack the necessary modules correctly (especially vfs_fruit -- start reading all the links from here on if interested in details: https://bugs.freenas.org/issues/5904) using SMB/CIFS between OS X and a linux machine will always cause headaches. Better use Netatalk/AFP instead.

Edited by silentcreek at Tue Oct 28, 2014 03:41

Since Debian Wheezy (on which repositories Bananian relies) comes with Samba 3.6 (quite old), you might look into installing a newer samba version from the wheezy backports repository. Just google how to install a package from backports in debian and upgrade samba.

Then, I'd try to make sure that you use a more or less identical smb.conf file and samba version when comparing the situation on Raspberry Pi and Banana Pi.

That being said, I don't have computers running OS X in my home network, so I can't share any experience in that regard. An iPhone and an iPad can access my Samba (3.6) shares without any problems though (via a third-party app).

Samba 4.1.11 is available in the Debian Wheezy backports repository:
https://packages.debian.org/wheezy-backports/samba

How to use:
http://backports.debian.org/Instructions/

You have to log in before you can reply Login | Sign Up

Points Rules