Other OS

OpenWRT on Banana Pi Router Board (BPi-R1)

31 25497
Edited by SaruMaaZ at Mon Nov 10, 2014 06:55

Hi all,

i looking for a functional OpenWRT Image for the new Banana Pi Router Board.
I have installed the Pre-Release OpenWRT Image for the normal BPi, the Router seems to boot the image, but i can´t find him in my network.
And only the red LED ist lightning, the green not.
I can´t login via SSH, Telnet or with the Luci webinterface, the default adress is 192.168.1.1, but i can´t find such a adress in my network...
The Router seems to work like a "Switch", with this image installed. But i can´t get Access to configure it.

Is the BPi Image ok, or should i wait for a spezial Image for the Bpi-R1 board?
How can I configure the R1 over ssh, telnet oder something else, without an display or keyboard (because OpenWRT doesn´t have a video output)?
Can i reach the Router over the LAN ports or over the WAN port?
Is there anyone else that have that problem too?
Or someone that have installed the OpenWRT on the Router successfully?

I have used the "OpenWrt_For_BananaPi_v1.0" Image from this page, but it doesn´t work correctly on the Router. (I cant reach the Router).

Edit: I have tested Arch Linux on the Router, it works correctly (System only, but no Network - Only the Wireless connection works). Only OpenWRT is not working yet.
Hi,

i have the same Problem.

Hi
I can ping the Banana Pi with OpenWRT but I can't open the Luci webinterface (only see the login) and also the ssh login is not possible with root/bananapi
BR

Did you use the WAN-Port or one of the Switch-Ports? I don't get a Link on the Switch Ports (The Lights stay dark)

hi, @hermannf which port have used to ping youre pi successfully, the WAN or one of the 4 LAN ports?
I have testet it on all ports, without a ping success...

The first login with LUCI is without an password!  (username "root" with an empty password) To login via SSH, you have to set an password via Telnet or over Luci.

http://wiki.openwrt.org/doc/howto/firstlogin

hermannf replied at Wed Nov 5, 2014 12:43
Hi
I can ping the Banana Pi with OpenWRT but I can't open the Luci webinterface (only see the login) ...

the default password for root user is nothing. Just click the login button,then set the new password is ok.

Edited by hermannf at Thu Nov 6, 2014 12:58
SaruMaaZ replied at Wed Nov 5, 2014 13:01
hi, @hermannf which port have used to ping youre pi successfully, the WAN or one of the 4 LAN ports? ...


Hi
I have only 1 port. Standard Banana Pi
BR Hermann

popboy126 replied at Wed Nov 5, 2014 22:30
the default password for root user is nothing. Just click the login button,then set the new passwo ...

Hi
I can only see the black page with one word "Lucy"
To open the black page I need about 5 minutes. I think the webinterface is not running right.
br hermann

Sorry
I havn't a Router Board (BPi-R1)!
sorry

hermannf replied at Thu Nov 6, 2014 12:57
Hi
I can only see the black page with one word "Lucy"
To open the black page I need about 5 minute ...

Do you try any other browser? I test the chrome. It can open the web page without any errors.

You have to log in before you can reply Login | Sign Up

Points Rules