New Custom Rom with new Custom Kernel from scratch

174 45191
mattrix  
Made a new post here:
http://forum.lemaker.org/thread- ... ironment_setup.html

Handy for "newbies" who don't have a current VM etc

Again, big thanks for zrox!

zrox  
Edited by zrox at Sun Nov 9, 2014 12:50

Hi all,

thank you

zrox

liab  
What ist wrong? Compiling ends with:

INFO: build u-boot OK.
INFO: build rootfs ...
INFO: skip make rootfs for android
INFO: build rootfs OK.
INFO: build lichee OK.

Then I rename .../output/...bimage to vmlinux.

Then I use a win PC with DragonFace and load a Android image. I tried Android_For_BananaPi_v2_0.img, stock.img and android_for_bananapi_4.4_beta1.img.

In CPFOP I changed vmlinux and in FSOP the new modules. Last I don't know what to do exact, replace the old modules or only insert to modules the folder 3.4, or move the ko's from the folder 3.4 to the folder modules. I tried all possibilities.

But the image will not boot. It hangs with the Android picture.

liab  
Sorry, I missunderstood this line, not saw the space:
cp arch/arm/configs/banana_pi_config .config
Now it works!
Now I shall try it with Drivers for Realtek PHYs.

ChrisP  
Check the Mattrix links above, based on his building env I successfully made my first working kernel, just excited ;)

I also succeded to make my K400 detected ! But only touchpad is working right now, keyboard is not typing anything (yet !).

liab  
I tried it with
CONFIG_REALTEK_PHY=yes
but LAN will not work.

liab  
Edited by liab at Sat Nov 8, 2014 22:35

I tried all, yes to all phy and changing emac and gmac. Nothing, LAN not working. In some info's about the Banana one can read Android LAN not working, perhaps this is an older source.

One mistake (only warning) is in .../drivers/net/.../Kconfig. The end of the line 10 is missing a ". But that's not the reason for the not working LAN

mattrix  
I've now been able to fix the Ethernet issue, so zrox - you may want to build a new image with the fix.
Just follow my instructions here: http://forum.lemaker.org/thread- ... ironment_setup.html

zrox  
Hi Matrix,

yea good work

I saw it I synced right now your changes from the git, I have Ubuntu  native running...
I will compile a new Kernel and set up a new Image

zrox

zrox  
Edited by zrox at Sun Nov 9, 2014 13:02

Hi all,

the new Image is up

By the way, I played a little bit with bluetooth, I enabled also bluetooth and removed the CSR BlueCore devices from the blacklist,
but the problem yet is the bluetooth stack is not compiled in our Android image.
For this probem we will find also a solution, I think I give a try to the cubietruck sources and enable the generic bluetooth stack.

We will see If I have luck.

zrox

You have to log in before you can reply Login | Sign Up

Points Rules