New Custom Rom with new Custom Kernel from scratch

174 43140
mattrix  
Sounds great.
Please let me know any fixes / additions and we will get them into that GIT Repo!

Have you had any luck getting a different WIFI module working?
They are built by default as modules, and I tried just using a insmod without any luck.

ridfa  
Hi zrox,
I tried your new version but my mouse m210 doesn't work with USB dongle unifying. Do you know how to resolve this issue? I think it is driver issue but I am a newbie
Thanks

zrox  
Hi Matrix,

I didn't tested yet other wifi sticks, I think just a insmod will not work check the init.sun7i.rc.

Hi Ridfa,

I checked the Kernelconfig and the EHCI (USB 2.0) mode is enabeled but I think also that it is a problem with the sunix USB driver,
I will check if it is a patch for this problem available.

zrox

ChrisP  
Edited by ChrisP at Mon Nov 10, 2014 01:44

You have to add these options in the kernel:

    Device Drivers  --->
       
  • HID Devices  --->
                    {*}   Generic HID support
           
  •      /dev/hidraw raw HID device support
                    <*>   USB Human Interface Device (full HID) support
                    Special HID drivers  --->
                            <*> Logitech devices
                            <*>   Logitech Unifying receivers full support

    using getevent in terminal emulator (after a su), I can see that keyboard is physically working, but cannot use it yet, even by activating physical keyboard. It's working ilke a charm with the Android 4.4. Wondering what is still missing...

    I tried the same for IR by the way, after changing ir_rx value name to ir0_rx in config file, but still no events are sent.
  • orbit  
    I have still had no luck getting ethernet going with the new image.

    liab  
    Many thanks to zrox & mattrix. I mixed - lichee from the instruction xrox and linux3.4 from the mattrix git and compiled it. Now LAN works fine!

    orbit  
    Do you have an image you would like to post? I would love this image with working Ethernett.

    liab  
    Edited by liab at Mon Nov 10, 2014 14:30

    You have right, with AND-MoD-New-kernel-2014-11-09.img LAN will not working. Try this, good luck.
    https://www.dropbox.com/s/c7ysv8yo6vicdqa/test11.img?dl=0

    I test it, for me the xbmc version from the stock image works more stable.

    ridfa  
    Hi ChrisP,
    thanks for your response.
    @ zrox, can you try that's CrisP said?
    Thank you

    liab  
    Edited by liab at Mon Nov 10, 2014 22:11

    I compiled a driver for the WLAN-Stick RT5370STA.
    Just I find out, that copying the module ra5370sta.ko to the fsop folder /fsop/system/vendor/modules/ is not real possible. It seems to go,
    but after save and restart dragonface with the saved one, all new modules are lost and all modules are the old modules from the original image.

    The only way to copy the modules is with linux direct in sdx7 folder /vendor/modules/.

    You have to log in before you can reply Login | Sign Up

    Points Rules