Trouble

OVERSCAN

13 13571
I cannot change the overscan when using HDMI, i've tried everything possible with config.txt

right down to deleting it all together and manually writing one
which is currently just:

disable_overscan=0
hdmi_force_hotplug=1
overscan_left=200
overscan_right=200
overscan_top=100
overscan_bottom=100


it would appear that the banana pi is completely ignoring these settings, any insight on how i can address the missing portions of my screen would be appreciated.
Banana pi do not use this confilg file, it use the script.bin in the first partion. The file you use is for raspberry pi

Tony, thank you for your response, however on the Raspian build i could not locate this file.  i will check again, i would not put this past user error.
--Ducky

Reply 3# duckyvirus

It is in the first partition of the SD card. In Raspbian v2.0, the 1st partition is not auto mounted.

yes, i found it, and then upgraded to 3.0 (thank you by the way, nice build).
however the script.bin does not allow for overscan adjustment that i could find on the wiki.  i broke down and got an HDMI -> DVI adaptor for the troubled monitor so its a hack, but works.

the overscan thing will need to be sorted, i might break down and build an utility python script to modify the xorg.conf to do this if needed for my RetroPi conversion project.

http://sunxi.org/Fex_Guide#.5Bdisp_init.5D Here you can see it has two frequency p50 and p60.

yes, 50 vs 60 mhz are not what im discussing, what i'm referring to is the "padding" that some screens will have or need.  for example, with the raspberry pi i set the overscans (as seen in first post) [but not to that extreme] and it "padds" or shifts the image so that it fits properly in the display.  this is needed because some screens either over or underscan the image.

meaning that you either have black borders around your image or you are missing parts of it.
i'm trying to sort a way to adjust for them outside the script.bin as it doesnt seem to support it.  

i will post any findings here.

I know what you mean now. It seems that the script.bin and Env.txt can not do that function. But you can change the resolution in script.bin to fit your monitor, with screen0_output_mode to different value. It set to 480, 576,720,1080... But it seems no auto adjusting function, or maybe I don't know how to set.

Is there any possible to resize the screen of tv-out?
Analog tvout is possible to change the following configuration.

$sudo bash
#cd /boot/bananapi
#bin2fex script.bin > ucmd.txt
#vi ucmd.txt

[disp_init]
isp_mode = 1 #screen0 = 0, screen1 = 1
screen1_output_type = 2 # hdmi=3, tv=2
screen1_output_mode = 14 # ntsc=14, pal=12

#bin2fex ucmd.txt > script.bin
#reboot

It works fine!
But my TV could not show full size screen because overscan problem.
We need to add the following option like RPI
overscan_left=200
overscan_right=200
overscan_top=100
overscan_bottom=100

I'm afraid it doesn't seem possible as the display drivers do not support overscanning.
I've tried all sorts of stuff from xrandr to fbset to manual modelines but to no avail.

You have to log in before you can reply Login | Sign Up

Points Rules