Interfacing

1-wire and Dallas DS18b20

34 19975
tkaiser  
luetzel replied at Tue Jan 20, 2015 08:02
No, unfortunately, it wasn't enough to set the frequency scaling in rc.local. Only both, keeping t ...

Ah, good to know.

Have you tried already mainline kernel (there the whole cpufreq thing is currently missing/different)? The most simple way seems to be trying out one of Igor's images with kernel 3.19.0-rc4: http://www.igorpecovnik.com/2014/09/07/banana-pi-debian-sd-image/

If the problem persists then it might be worth to bring it to the attention of the kernel hackers actively developing mainline/sunxi-next.

I've had myself cpufreq related problems with 2 DHT22 (when cpufreq exceeded 1008 MHz they didn't work reliable any longer) but currently not the time to dig in deeper.

luetzel  
So far I've tested only the stable 3.4.103 branch. I would like to test a different kernel, but at the moment I do not have access to a second BananaPi. Currently, my BananaPi runs headless as a self-hosted WebServer (Nginx/Wordpress/MySQL), so I don't want to make any changes except bug fixes. Except for the cpu_freq issue, the system is very stable with an uptime of more than 4 to 6 weeks. I prefer to run a customized kernel with less hardware support (don't need GPU, eth0 support and other things at all).

Roel  
Hi everyone,

After following the instructions, I only found "w1_bus_master1" in "/sys/bus/w1/devices".
The temperature sensor worked without problem when I had it connected to an Arduino.

I tried to follow along with the steps described in this thread and here:
http://www.linuxx.eu/2014/09/ban ... 7712839943464951942

I found "script.bin" in "/boot" directly, there was no "/boot/bananapi". (running Raspbian GNU/Linux 7 (wheezy)) I copied the modified version of script.bin to both positions for good measure. (tried only overwriting the old file, without success)

I don't see any error message or other clue.
Do you have an idea what more I could try?

Thanks in advance!

Not sure if my post still is valid, I tried this a long time ago but it worked:
http://forum.lemaker.org/forum.p ... 12&fromuid=1602

Roel  
Thank you, i did come across your post,
Unfortunately I still can't figure out how to make the Bananapi read the sensor.
My CPU frequency seems high enough:
sudo cat /sys/devices/system/cpu/cpu1/cpufreq/cpuinfo_cur_freq
720000

In a link in the post you linked to:
https://learn.adafruit.com/adafr ... ure-sensing/ds18b20
There is a file mentioned which I don't have: /boot/config.txt

I assume this is a difference beween Raspberrypi and Bananapi, am I right?

Just curious, does the folder /sys/bus/w1/devices/28-*** appear and disappear directly when you connect or remove the sensor, or does this require a reboot?

You have to log in before you can reply Login | Sign Up

Points Rules