Android Mattrix KODI Image - V3.2 - 08/12/2015

294 95859
mattrix  
I think we could do a system link pointing from the .xbmc location of the passwords file to the new .kodi location to trick SMBWrapper

dlanor  
Yes of course, that should work fine !
I must be too tired to think straight, since I missed that...  ;)

But a single link may not do the trick, unless we also create a fake folder to put it in, since the 'kodi' name occurs in more than one place of the folder tree.

I'll think I'll hang on to my last SD card prepared with Kodi for testing that, though I'll first make a test with another card using the new image you made, as the quickest way to verify that SMBWrapper does its job properly for XBMC, before trying it with Kodi.

Best regards: dlanor

dlanor  
Edited by dlanor at Sat Nov 15, 2014 08:05

I'm sorry to report that in my recent tests I get exactly the same kind of result with SMBWrapper as I earlier got for XBMCWrapper.
There is now a long delay with spinning circle until 'MX Player' times out its access attempt and gives the message that it can't play the video.
This is surprising, as a number of people have described it as working with Gotham, but there must be some difference between their setups and mine.

One possible difference which comes to mind is that they may have had files stored in the base path for which the password was registered by XBMC, whereas my files always are in some subfolder beneath that level. If SMBWrapper checks folder match by precise match of the full string, then that is bound to fail. It needs to check that the registered path for a password is included as a leading string in the current access path, in which case that password should be used.

----- some tests later -----

Now I'm really confused, but positively surprised as well. After several tests with negative results I decided to make a test by defining a video source link for XMBC with video files at the top level (due to my suspicions above), and playing these through SMBWrapper + MXPlayer worked fine. But when I then started testing other files, not in that top folder but further beneath it, these too worked fine. But all files under the video source link defined earlier still fail every time, so that's very confusing. There's nothing wrong with the definitions or the passwords, as those files play fine if I remove the playercore file so XBMC plays them directly, so there must be something about them that doesn't work for SMBWrapper.

Best regards: dlanor

Wieczor  
Can I have link od Googledrive ? Cant download from MEGA

dlanor  
Edited by dlanor at Sat Nov 15, 2014 08:47

Further tests show a slight pattern:

I've tried to access files on four different computers.
One of them runs 'Windows XP'. It's access fails to work with SMBWrapper, though it works fine with XBMC otherwise.
Another runs 'Windows 7'. It's access by XBMC follows the same pattern as for XP. (fails with SMBWrapper, works without it)
Two run 'Windows 2003 server'. Their access by XBMC works fine both with and without SMBWrapper.

NB: When I say access above I really mean playback, as file browsing access works fine for all cases.

It is a pattern, but I can't make sense of it.
What could SMBWrapper do differently from XBMC in its SMB path strings, such that they fail with 'desktop' OS versions and only work with the 'server' OS ?

At this point I'm breaking off my tests for today, as I'm getting too tired.

Best regards: dlanor

Wieczor  
Edited by Wieczor at Sat Nov 15, 2014 11:31

My download speed via ssh to usb stick is max 1MiB/s normally I have about 8MiB/s how can I make it faster ?
when I use ftp droid i have error cant change directory to ; .......... no such file or directory propably i set up ftpdroid wrong but i tried everything
sabadroid connection 4MiB/s but suddenly qbittorrent error invalid argument

Btw

I want to download files on my linux mint (wifi connection) to hdd connected to banana pi (lan connection)

dlanor  
Edited by dlanor at Sun Nov 16, 2014 02:44
Wieczor replied at Sat Nov 15, 2014 10:32
My download speed via ssh to usb stick is max 1MiB/s normally I have about 8MiB/s how can I make it  ...


Assuming your Linux setup also supports SMB, that would offer another method for copying stuff to the BPi.

Several file managers for Android offer SMB support, and one of the best is 'ES File Explorer'.
This is what I always use myself for copying stuff to the BPi from computers, or to move stuff between storage drives of the BPi.

So I handle the transfers from the BPi side, not from the computer side, by first defining the computer(s) as server entries in the LAN section of 'ES File Explorer', including username and password entries for the computer(s), after which I navigate through those server entries to the HDD listings of the computer(s) and select the stuff for copying.

It may take a few runs to get used to how that program works and how it handles such copying (single window copy-paste method), but it works very well.

Best regards: dlanor

w84  
First of all, thanks for this great image Mattrix.

But now my question: I tried to play some videos over the network and I encountered some problems with audio of video files (no audio) so I installed the dts codec for mxplayer. Now the audio of the videos works fine when I play videos from a local source (I mounted an USB stick with some videos on it), but when I try to play the same MKVs over the smb network I again have no audio. Audio files play fine over the network and menu sounds too. What do you think the problem is? Is it a SMB problem?

orbit  
Are there specific usb wifi dongles that this image supports?

siu_ma  
Edited by siu_ma at Sun Nov 16, 2014 22:14

Greeting to all, I just got my banana yesterday and installed mattrix 1080p version , I also can't get my edup ep-n8508gs (realtek 8188cus) to work under android environment. I downloaded the android driver from realtek but seems like installing the driver is more difficult then I expected

You have to log in before you can reply Login | Sign Up

Points Rules