Kernel 3.4.90 Headers

12 14085
I have created a Kernel tarball and headers package. Everyone who want to use can download it. I could not promise it works well, just a trial.

Download Link:
I installed, but I still get this compile error ;

make[2]: Entering directory `/usr/src/linux-headers-3.4.90'
  CC [M]  /usr/src/astsrc_321/zaptel/kernel/pciradio.o
In file included from /usr/src/linux-headers-3.4.90/arch/arm/include/asm/domain.h:14:0,
                 from /usr/src/linux-headers-3.4.90/arch/arm/include/asm/thread_info.h:28,
                 from include/linux/thread_info.h:53,
                 from include/linux/preempt.h:9,
                 from include/linux/spinlock.h:50,
                 from include/linux/seqlock.h:29,
                 from include/linux/time.h:8,
                 from include/linux/stat.h:60,
                 from include/linux/module.h:10,
                 from /usr/src/astsrc_321/zaptel/kernel/pciradio.c:47:
/usr/src/linux-headers-3.4.90/arch/arm/include/asm/barrier.h:41:27: fatal error: mach/barriers.h: No such file or directory
compilation terminated.

How do I install this?

Reply 3# Ligachamp

You'd better pull down the source code from LeMaker Github https://github.com/LeMaker to compile your customize driver.

Post Last Edited by dranswer at 2014-8-26 13:21

Does anyone have instructions on where to find Bananian headers or how to create them? Even instructions on how to install and use the ones mentioned in this thread would be very helpful.

Haven't tried the tarball provided by the op but you could use the source tree from LeMaker
1.Clone the kernel sources from LeMaker's git to /usr/src directory
git clone --depth=1 https://github.com/LeMaker/linux-bananapi.git /usr/src/linux-bpi

2.Copy over the running kernel's .config file to the above source directory.
zcat /proc/config.gz > /usr/src/linux-bpi/.config

3.Copy over Module.symvers file to the source directory
http://forum.lemaker.org/attachm ... lWVpadkQrdTVsQWc%3D

4.from a terminal cd into /usr/src/linux-bpi and run the fol. commands(which prepares the sources for compiling out-of-tree modules)
make menuconfig
make prepare
make scripts

5.Create a symlink in /lib/modules/3.4.90 called "build" and pointing to /usr/src/linux-bpi
cd into /lib/modules/3.4.90
ln -s /usr/src/linux-bpi build

You may try and see if it works.

Edited by Keeze at Sat Nov 29, 2014 05:41
sashijoseph replied at Tue Aug 26, 2014 21:23
Haven't tried the tarball provided by the op but you could use the source tree from LeMaker
1.Clone  ...

Hi sashijoseph,

Great post, but I ran into 2 minor problems and I have one addition.

1) instead of make menuconfig, I use make oldconfig
2) I pulled Modules.symvers from this thread, because the link you provided is dead: http://forum.lemaker.org/forum.php?mod=viewthread&tid=2447
3) Case the enviromentvariable arch is not arm, but armv7l, I created a symlink in the sourcefolder with ln -s /usr/src/linux-bpi/arch/arm /usr/src/linux-bpi/arch/armv7l

Now my drivercompilation workes flawless.


Hi all,
I'm trying to compile my new USB Ethernet (ASIX AX88179). I've followed the suggested manipulation above but I still getting an error when I try to load the generated module
  1. # modprobe usbnet
  2. # insmod ax88179_178a.ko
  3. Error: could not insert module ax88179_178a.ko: Invalid module format
Copy the Code
This error seems to be related to an incoherency with the downloaded kernel header. My kernel version is: 3.4.90+
To obtain the kernel header I've used the command:
git clone --depth=1 https://github.com/LeMaker/linux-bananapi.git /usr/src/linux-bpi

All tasks described above worked for me until I got the error when trying to load the module. Below the modinfo output:
  1. # modinfo ax88179_178a.ko
  2. filename:       /root/Downloads/AX88179_178A_LINUX_DRIVER_v1.12.0_SOURCE/ax88179_178a.ko
  3. license:        GPL
  4. description:    ASIX AX88179_178A based USB 2.0/3.0 Gigabit Ethernet Devices
  5. author:         David Hollis
  6. srcversion:     D7EDD7270F552458E4B910D
  7. alias:          usb:v04E8pA100d*dc*dsc*dp*ic*isc*ip*
  8. alias:          usb:v0930p0A13d*dc*dsc*dp*ic*isc*ip*
  9. alias:          usb:v17EFp304Bd*dc*dsc*dp*ic*isc*ip*
  10. alias:          usb:v0DF6p0072d*dc*dsc*dp*ic*isc*ip*
  11. alias:          usb:v0B95p178Ad*dc*dsc*dp*ic*isc*ip*
  12. alias:          usb:v0B95p1790d*dc*dsc*dp*ic*isc*ip*
  13. depends:        usbnet
  14. vermagic:       3.4.103+ SMP preempt mod_unload modversions ARMv7 p2v8
  15. parm:           msg_enable:usbnet msg_enable (int)
  16. parm:           bsize:RX Bulk IN Queue Size (int)
  17. parm:           ifg:RX Bulk IN Inter Frame Gap (int)
  18. parm:           bEEE:EEE advertisement configuration (int)
  19. parm:           bGETH:Green ethernet configuration (int)
Copy the Code
I ve also tried to install using apt-get but I'm confusing with the listed option. I dont know which one I can choose.
  1. # apt-get install linux-headers
  2. Reading package lists... Done
  3. Building dependency tree      
  4. Reading state information... Done
  5. Package linux-headers is a virtual package provided by:
  6.   linux-headers-3.2.0-4-vexpress 3.2.63-2+deb7u1
  7.   linux-headers-3.2.0-4-omap 3.2.63-2+deb7u1
  8.   linux-headers-3.2.0-4-mx5 3.2.63-2+deb7u1
  9.   linux-headers-vexpress 3.2+46
  10.   linux-headers-omap 3.2+46
  11.   linux-headers-mx5 3.2+46
  12. You should explicitly select one to install.

  13. E: Package 'linux-headers' has no installation candidate
Copy the Code
Could you please point me how can I obtain the linux-headers compatible with my distrib?
Help me please I'm struggling since a couple of days :-(


Edited by slamer at Wed Dec 10, 2014 07:30

Your help will be appreciated!

Any update on how to get and install the headers?

You have to log in before you can reply Login | Sign Up

Points Rules