Lubuntu

Re: crashplan on Banana Pi

6 3939
ChrisB  
Hello!

I'm hoping to get a CrashPlan backup server going on a Banana Pi.

Has anyone here had any success on this?

It seems doable as there's quite a few people having done it on Raspberry, e.g.
http://melgrubb.wordpress.com/20 ... -part-10-crashplan/

It sounds like Raspberrys can be a bit underpowered for this task so i thought it would make more sense to use a Banana pi!

I'm most familiar with ubuntu-range of linux so I'd like to stick with that if possible.

Cheers,
Chris.

p.s. feel free to move this if it's in the wrong category.
Looks promising... go ahead!

ChrisB  
Edited by ChrisB at Sat Nov 22, 2014 02:07

Hello All!

So I tried again with a bit more sleep and success! Is fairly straightforward thanks to other people doing the hard work!

Instructions for installing CrashPlan on banana pi are as follows.

This guy's instructions were great:
http://melgrubb.wordpress.com/20 ... -part-10-crashplan/

(There's a few instructions around using different sorts of Java. This post seems to be one of the newer ones.)

I used Lubuntu (v3.1.1) and this extra code to get Java working
  1. sudo add-apt-repository ppa:webupd8team/java
  2. sudo apt-get update
Copy the Code
Then Melgrubb's normal installation command, i.e.
  1. sudo apt-get install oracle-java8-jdk libjna-java
Copy the Code
. Then follow Melgrubb's instructions.

The only other thing I did differently, was changing this:
  1. sudo cp /usr/lib/java/swt-gtk-3.8.0.jar /usr/local/crashplan/lib/swt.jar
Copy the Code
to this:
  1. sudo cp /usr/lib/java/swt-gtk-3.8.2.jar /usr/local/crashplan/lib/swt.jar
Copy the Code
(version number difference, might just be that his post is a few months old...?)

I also found these commands quite useful (I didn't get a shortcut like Melgrubb's suggests):
Go to /usr/local/crashplan/bin then
./CrashPlanEngine status
./CrashPlanEngine start
sudo ./CrashPlanDesktop
Note that: you need to start CrashPlanDesktop with sudo rights otherwise it won't find the backup engine.

Cheers!
Chris.

Hi,

just a comment. I had crashplan running on a sheevaplug for a couple of years. After updating to the Banana Pi I could not make it work on bananian for the life of myself.
Lubuntu 3.1.1 worked like a charm in ten minutes. (I believe there is an issue with jna)

Best.

This worked for me too. I just then followed the instructions on how to setup a headless box and BAM all my stuff is being backed up. Compared to my raspberry pi the Banana pi backs up a little faster. Also noticed with java 8 that the cpu doesn't get pegged at 100% either.

hvdwolf  
Edited by hvdwolf at Sun Mar 8, 2015 10:06

I just installed CrashPlan Free on bananian 15.01. I could follow the entire MellGrubbs post including the
  1. sudo cp /usr/lib/java/swt-gtk-3.8.0.jar /usr/local/crashplan/lib/swt.jar
Copy the Code
as I assume the debian repositories are stil on 3.8.0 and not 3.8.2.

The current issue I have is that I can't get the CrashPlanDesktop to run (yet).
So I use the very simple work-around of using a remote CrashPlanDesktop from my laptop to the headless bananapi as described in the Code42 article Using CrashPlan on a headless computer

I will dive into it but I don't think I'm going to need it much anyway. On my previous Ubuntu server I hardly touched it.

Edit: There is one thing I forgot to mention: I did not update to a newer version of java from some ppa. I used the defaulty available OpenJDK 1.7 from the repositories.

Couple of additional things to note.

There doesn't seem to be a package named 'oracle-java8-jdk'. So you may need to use this line instead.

  1. sudo apt-get install oracle-java8-installer libjna-java
Copy the Code


Also the link to 'jre' installed with crashplan is wrong so you need to use a symbolic link. As follows:

  1. sudo rm -r /usr/local/crashplan/jre
  2. sudo ln -s /usr/lib/jvm/java-8-oracle /usr/local/crashplan/jre
Copy the Code

You have to log in before you can reply Login | Sign Up

Points Rules