Lubuntu

[SOLVED]automount fstab -> selinux missing

5 9792
Tonband  
Edited by Tonband at Wed Nov 26, 2014 00:37

Hi there,

again, i have a problem while mounting my usb-hdd before starting xbmc.

i tried to add my hdd to /etc/fstab, but that doesn't work. After creating the entry, i restarted and the system didn't come up, because of this error:

  1. MOUNT failed for selinuxfs on /sys/fs/selinux: No such file or directory
Copy the Code
ok, so it looks like selinux is not installed.

  1. sudo apt-get install selinux
Copy the Code
doesn't work, cuz

  1. selinux: PreDepends: grub-pc but it is not installable
Copy the Code

What's is wrong here? It says, that it is maybe not created yet for this OS. Thought it is just recompiled for BananaPI, so selinux would be installed?
How to get it work, any suggestions?

EDIT: think the problem is, that selinux is not enabled in the kernel? Can anyone confirm?
How does your fstab look like? Actually a USB hard drive should have nothing to do with selinuxfs.
And yes, selinux is not part of the standard LeMaker kernel configuration. Don't know if that is any different for Lubuntu, but I doubt it. Anyway, it should be easily possible to mount your USB harddrive without SELinux (btw. stock Ubuntu does not ship with SELinux either).

Just to give you an example of how I mount one of my USB drives:
  1. UUID=a4ca6a84-6a9e-47bb-a939-0c4b8d4e3cd4       /media/music  ext4    defaults,acl,rw,noatime,noexec,nosuid,nodev 0       1
Copy the Code
Of course, the line depends on what filesystem you use and which options you want to use. I just wanted to say, it's possible to mount USB drives without SELinux.

You could try USBmount for auto mounting and unmounting.

USBmount

Tonband  
Edited by Tonband at Tue Nov 25, 2014 12:23

hi silentcreek, thanks to your snippet!
mine is:

  1. UUID=AAVF-F0F3 /media/myUSBHDD    vfat    default 0       0
Copy the Code
which doesn't work. It would be very nice to solve that without selinux, but the logs say, it depends on selinux

First off, "default" is missing an "s" at the end. It should read defaults.

Second, have you tried to run
  1. sudo mount -t vfat UUID=AAVF-F0F3 /media/myUSBHDD/
Copy the Code
during runtime in a shell? Do you get the same error?

Also, have you double checked that the UUID is referring to the correct partition and not some other hidden partition on that drive that might not be FAT?

Tonband  
Oh no! That was all! The 's' was missing.
Thank you, silentcreek!

yeah, sudo mount was always working, entry in fstab not....damm!!!!

You have to log in before you can reply Login | Sign Up

Points Rules