Bananian

ASUS USB-N10 WiFI on Bananian

2 3047
Edited by NightStorm at Mon Nov 24, 2014 10:39

Hi.
I tried to use my ASUS N10 WiFI USB Dongle on my new Banana Pi.
But i could not get it to run.
I think there are drivers missing.

I tried to install the Driver Package from the ASUS Side but the install.sh always failed with the Error:
"/lib/modules/3.4.104+/build" - no such file or directory"
  1. make ARCH=armv7l CROSS_COMPILE= -C /lib/modules/3.4.104+/build M=/root/driver/RTL8188C_8192C_USB_linux_v4.0.5_11249.20140422/driver/rtl8188C_8192C_usb_linux_v4.0.5_11249.20140422  modules
  2. make: *** /lib/modules/3.4.104+/build: no such file or directory.  End.
  3. make: *** [modules] Error 2
Copy the Code
WLAN Chip is a RTL8188CUS
Details about the Dongle: https://wikidevi.com/wiki/Asus_USB-N10_Nano
Keeze  
Done it for a Realtek 8192EU....

You need to install the kernel sources first. Follow the instructions here: http://forum.lemaker.org/forum.p ... 7&fromuid=61937

Change point 1 to:
git clone --depth=1 https://github.com/Bananian/linux-bananapi.git /usr/src/linux-bpi

and at 3. use the attached Module.symvers.

Good luck!

Module.zip

139.96 KB, Downloads: 119

vushu  
hello Im not sure about how to do the 2 step?
do i just copy my driver.gz filer in /usr/src/linux-bpi/.config ?
it say permission denied even with sudo.

You have to log in before you can reply Login | Sign Up

Points Rules