Trouble

[Solved]Sound analog works. HDMI kinda.

3 3425
Edited by Memleakz at Thu Dec 11, 2014 11:00

Hello bananapi forum.

Let me first say i so far njoy the board very much, having received it a few days i got it installed in no time and got browsing and other things tested and all worked well!

but when playing sound i encountered some issues.

i run:
Raspbian_For_BananaPi_v3.0 with hdmi to a sony bravia
tv.

I investigated allot on the internet and found the following postings:

http://forum.lemaker.org/thread-213-1-1-.html
http://www.bananapi.com/index.ph ... for-banana-pi-image

I can confirm that the bananapi does indeed play sound as it works over analog jack stick but i cant for the life of me figure out how to
get the banana to play it over hdmi on my sony bravia tv.

i tried to tweak the asound.conf and this made me able to test the jack as it seems to be outputting on hdmi default as it should.
i also found out that doing  a speaker-test  DOES output sound over hdmi and analog which i find incredible weird.

Mediaplayers i tried:
VLC
Mplayer

both work over analog but not hdmi.

I should also mention that i had to tweak the setting on my tv to get correct display of video input. what i did exactly was to change the display area setting to Full Pixel
as described here:

http://ubuntuforums.org/showthread.php?t=1795124

doing this gave me good screen fitting video which is leading me to believe that maby my TV has some funky setting ? or maby i missed something totaly ? not having used linux for other then for limited work environments i am not very well versed in general problem solving.

Hope some kind soul has some insights
So here is a little update.

I tried allot of stuff with my raspbian system and could at max get some scratching out of the video after trying pulseaudio but it would only last a few seconds and then would stop totally.

Now i have tried to install lemedia and to my big surprise there was fine sound in the menu to begin with. i the entered a systems menu and sound seem to have gone again. this is a funky bug.

I will try to reflash with a new lemedia to see if sound comes back. but i am pleased that i did hear sound and i found the nice little video of the lemaker factory nice stuff

will post some more detailed output data from vlc / mplayer on raspbian as they seem to be decoding the sound just fine. could be interesting to know the differences why lemedia works but raspbian doesn't.

the plot thickens

So here is some more technical information from the banana running files with mplayer as it outputs allot of information to console:

1. playing a wav file

Playing fly_right.wav.
libavformat version 53.21.1 (external)
Mismatching header version 53.19.0
Audio only file format detected.
Load subtitles in ./
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 11025 Hz, 1 ch, u8, 88.2 kbit/100.00% (ratio: 11025->11025)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] 11025Hz 1ch u8 (1 bytes per sample)
Video: no video
Starting playback...
A:   2.0 (01.9) of 2.0 (02.0)  0.0%


Exiting... (End of file)

2. playing a video:
pi@lemaker ~ $ mplayer big_buck_bunny.mp4
MPlayer svn r34540 (Debian), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing big_buck_bunny.mp4.
libavformat version 53.21.1 (external)
Mismatching header version 53.19.0
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0xb63f2ee8]max_analyze_duration reached
[lavf] stream 0: audio (aac), -aid 0, -alang eng
[lavf] stream 1: video (h264), -vid 0
VIDEO:  [H264]  640x360  24bpp  24.000 fps  612.2 kbps (74.7 kbyte/s)
Clip info:
major_brand: mp42
minor_version: 1
compatible_brands: mp42avc1
creation_time: 2010-02-09 01:55:39
Load subtitles in ./
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 22050 Hz, 2 ch, s16le, 65.1 kbit/9.22% (ratio: 8134->88200)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [pulse] 22050Hz 2ch s16le (2 bytes per sample)
Starting playback...
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Unsupported PixelFormat 81
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x360 => 640x360 Planar YV12
A:  20.5 V:  20.5 A-V:  0.002 ct:  0.042   0/  0 50%  2%  1.5% 2 0

Exiting... (Quit)

AND finaly the working one namely speaker-test -t wav:


pi@lemaker ~ $ speaker-test -t wav

speaker-test 1.0.25

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 8192 to 65536
Period size range from 2048 to 16384
Using max buffer size 65536
Periods = 4
was set period_size = 16384
was set buffer_size = 65536
0 - Front Left
Time per period = 0.358112
0 - Front Left
Time per period = 1.366514
0 - Front Left
Time per period = 1.704836
0 - Front Left
Time per period = 1.366647
0 - Front Left
Time per period = 1.364997
0 - Front Left
Time per period = 1.704862
0 - Front Left
Time per period = 1.366568
0 - Front Left

outputs good sound on both my tv speakers. hower the mplayers mplayer,vlc do not.
my next attempt will likely be arch linux and check if maby it has wider support for devices then the raspberry for banana.

Edited by Memleakz at Thu Dec 11, 2014 11:03

So on the hunt for the sollution to my issue it seems i finaly had the bright idea to try some more different video files both mp4 and avi and mkv.
and here are my results:

2 out of 4 mp4 files worked.
0 out of 1 mkv failed. ( pc too slow ? ) error
1 out of 1 avi file worked.

i will test some different mp3's aswell to see how well they do. but my issue is solved and the banana now delivers nice fullscreen video with sound over hdmi! wicked

it is worth noting that the mp4 video from http://www.quirksmode.org/html5/tests/video.html does not work on the bananapi! in case others do quick google and find it.

You have to log in before you can reply Login | Sign Up

Points Rules