Discussion

Change the language in Lubuntu ?

8 27728
Ipab  
I know the answer should be somewhere already but I really can't find it.
Can anyone tell me how to change the language in Lubuntu (V3) to German ?
I didn't try to change language. But there is mehod I Google, I don't try it. But you can have a try http://ubuntuforums.org/showthread.php?t=2146196

Ipab  
Thanks for your answer, but when I open the menu in the left there is preferences but any language setting.
Anyone else ideas?

NiFu  
when I open the menu in the left there is preferences but any language setting.

Same problem here: In "Preferences" no menu entry "Language Support" ...

Can some expert explain what program "should" start with "Language Support" ? Perhaps we can start the program manually by command line.

I have found a tutorial for enabling German language - see here:
http://www.itslot.de/2014/01/cub ... lubuntu-andern.html
  1. sudo locale-gen de_DE.UTF-8
  2. sudo update-locale LANG=de_DE.utf8
  3. sudo update-locale LANGUAGE=de_DE.UTF-8
Copy the Code
But for this commands I need to be root (su -root).
And when I login again all still in English.
But if I login as "root" all is in German.

I have found the modified settings in /etc/default/locale:
  1. #  File generated by update-locale
  2. LANG=de_DE.utf8
  3. LANGUAGE=de_DE.UTF-8
Copy the Code
But why does this not work for the desktop user ?

After long search I found that user settings are stored in $HOME/.pam_environment. Haven't seen this file before - because it is "hidden". After enabling hidden files I copied the entry's from file /etc/default/locale into $HOME/.pam_environment. And now nearly all is in German language (e.g. "AbiWord", "Filemanager"). Only some programs are still in English (e.g. "Document Viewer"). But I can live with this.

Reply 4# NiFu
So good!

mamiko  
auusgezeichnet !

charli  
There is a easy way to set the language on debian .Just run "sudo dpkg-reconfigure locales",and set your location. I think it is also working on Lubuntu.

jambay  
Just run "sudo dpkg-reconfigure locales",charli Posted at 2014-7-16 10:31

Works fine in Rasbian, too.

Ichigo  
Another way: install 'language support' via lubuntu software center, reboot, choose language support (where it should be), change to german (systemwide) and reboot.

You have to log in before you can reply Login | Sign Up

Points Rules