BaiDu WIFI on BananaPi

30 16808
The BaiDu WIFI can work on BananaPI now
If you want to test, please use the attachment.
put the RT2870STA.dat to /etc/Wireless/RT2870STA
put the mt7601Usta.ko where you want.

After system boot up, insmod mt7601Usta.ko. --> ifconfig ra0 up --> we can work through UI or command line.
I don't know why I can not add attachment, so I put in baidu pan.

密码: hagp

Reply 2# voiceshen

   Hi,    I have tried using your .ko and uImage but still not working. Would you please let me know the steps to build .ko ?

Reply 3# rbarua

do you get any errors with insmod?

what is the output of "ifconfig" ?

Reply 4# sashijoseph
When I tried sudo insmod with raspbarian_v3_1 uImage, it was not loaded as Invalid format. Then I copied the uImage attached above, even though it loaded but no ra0 or wlan0. I check with iwconfig, no luck

Reply 5# rbarua

   One more update, When I tried building mt7601u with 3.4.90 kernel, its giving error as
   No target rule for "modules"


   Is there any way where I can build the driver modules inside 3.4.90 kernel of raspbian 3.1?

Reply  rbarua
   One more update, When I tried building mt7601u with 3.4.90 kernel, its giving er ...
rbarua Posted at 2014-8-18 01:17

Hello, i've the same problem ?
And for the files gived in te first post,i get this error with the command :
insmod mt7601Usta.ko

insmod: ERROR: could not insert module mt7601Usta.ko: Invalid module format

thx for your help

Reply 7# Beetlejuice

   Yes, Same error I have also seen...

Reply 5# rbarua

after loading the module what does dmesg say?

Reply 9# sashijoseph
Getting following error:
[    6.980581] rtusb init rt2870 --->
[    6.996134] ===>rt2870_probe()!
[    7.005059] --> RTMPAllocAdapterBlock
[    7.014048]
[    7.014052]
[    7.014054] === pAd = f0261000, size = 851128 ===
[    7.014058]
[    7.024728] --> RTMPAllocTxRxRingMemory
[    7.037255] ERROR: 256 KiB atomic DMA coherent pool is too small!
[    7.037274] Please increase it with coherent_pool= kernel parameter!
[    7.078540] <-- ERROR in Alloc Bulk buffer for HTTxContext!
[    7.102653] ---> RTMPFreeTxRxRingMemory
[    7.119572] <--- RTMPFreeTxRxRingMemory
[    7.134694] ERROR!!! Failed to allocate memory - TxRxRing
[    7.144403] <-- RTMPAllocAdapterBlock, Status=3
[    7.161454] rt2870: probe of 1-1:1.0 failed with error -1
[    7.185132] usbcore: registered new interface driver rt2870


You have to log in before you can reply Login | Sign Up

Points Rules