Other OS

Fedora 20 for bananapi

10 8777
Salvo  
Here's the fedora 20 image.

https://www.dropbox.com/s/etdo3f ... api-fedora20.img.xz

Under linux you need to unpack it,
xz -d bananapi-fedora20.img.xz

and then write it to an 8G SD card like this
dd if=bananapi-fedora20.img of=/dev/mmcblk0 bs=16M

it's using the kernel from the Cubieboard ubuntu image. So the modules will not work. But stock ethernet works.
Enjoy!
Wonder  
Reply 1# Salvo


    Very Great Job,

vk4tux  
waste of time without a genuine fedora kernel

tjyang  
waste of time without a genuine fedora kernel
vk4tux Posted at 2014-6-27 05:08


Hi vk4tux,


Can you explain more why you reach this comment of wasting time by not using "genuine" fedora kernel ?
Also what steps need to be taken to fixed this issue ?


Thanks


tj

deenbee  
Great job congratulations for all banana team

tigher  
Hi all. New here. Have looked but can't see this problem fixed elsewhere. Correct me if wrong. Feels like a kernel issue.
RE: F20 image from google download area. v1412. Banana pi.

After config of trunking, /var/log/message file filling with following message.
kernel: [17196.288521] GMAC TX status: VLAN frame

vk4tux replied at Fri Jun 27, 2014 05:08
waste of time without a genuine fedora kernel

If you want a genuine kernel, BerryBoot (a dual-boot or more if you want boot loader made for the Pis) lets you download genuine Fedora 21 ARM.

tigher  
tigher replied at Sun Mar 8, 2015 16:06
Hi all. New here. Have looked but can't see this problem fixed elsewhere. Correct me if wrong. Feels ...

Bump!
Any news/views/info please?

tigher  
I guess you have to ask the question : Is this forum of value? Little evidence to support a yes. Where are the experts and supporters? What a let down!

Edited by tigherII at Tue Mar 17, 2015 11:00

v1412. Quagga. ripD is producing error messages such as:
2015/03/17 15:34:28 RIP: can't set sockopt SO_REUSEPORT to socket 11
2015/03/17 15:34:28 RIP: RIPd 0.99.22.4 starting: vty@2602
2015/03/17 15:34:29 RIP: can't set sockopt SO_REUSEPORT to socket 14
2015/03/17 15:34:29 RIP: can't send packet : Operation not permitted
2015/03/17 15:34:32 RIP: can't set sockopt SO_REUSEPORT to socket 14
2015/03/17 15:34:32 RIP: can't send packet : Operation not permitted

Even an empty conf will produce at least the first entry - very odd. The config works on other Fedora system. Can't find anything specific on web. Anyone here seeing the same?

You have to log in before you can reply Login | Sign Up

Points Rules