Lubuntu

Setup xrdp remote desktop

8 17634
hello,
i just tried to setup a remote desktop with my bananapi and lubuntu 3.1.1.
I did this before with an older rasberry and had no problems.
now i log on with my windows remote client and i just see a grey mesh with an x coursor.
I expect it to be a problem with the lubuntu surface.
Anyone can help ? what is the easiest way around to see the desktop ?

thank in advance
Chris
maxwell  
Post Last Edited by maxwell at 2014-8-9 16:33

Post Last Edited by maxwell at 2014-8-9 16:32

Hello Chris,
I don't use the windows RDP Client to remote control my BPi but
VNCViewer and it works pretty well. Maybe this could be a way for you?

My config looks like this:
//Install VNC:
  1. sudo apt-get install x11vnc
Copy the Code
//Set a VNC password for connection
  1. sudo x11vnc -storepasswd YOURPASSWORD /etc/x11vnc.pass
Copy the Code
//Edit /etc/lxdm/default.conf and set the following option
  1. xauth_path=/tmp
Copy the Code
//Make it start on reboot. Edit/create file /etc/init/x11vnc.conf like this:
  1. start on login-session-start
  2. script
  3. /usr/bin/x11vnc -xkb -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -forever -bg -rfbport 5900 -o /var/log/x11vnc.log
  4. end script
Copy the Code
That's it. Good luck.

Cheers
Maxwell

Hi,
this is my way, i had the  same problem:

Open console and install as root on your BPI:
apt-get install vino lxde xrdp
After installation type  vino-preferences and do your settings

Edit  /etc/xrdp/startwm.sh (i use nano) and change settings:

#!/bin/sh

if [ -r /etc/default/locale ]; then
. /etc/default/locale
export LANG LANGUAGE
fi

#. /etc/X11/Xsession    <----- Type a "#" and insert
. /usr/bin/startlxde

From my other PC  I use Remmina to control my BPI.

Greetings Rincewind

maxwell  
Ricewind's way works perfectly for me. The grey mesh turns into a nice Desktop after a couple of seconds. Thumbs up!

Cheers
Maxwell

thank you very much for the given information.
first it didn't work, but now after a fresh installation it does.
maybe i already tried too many workarounds and lost control of the packages i installed

Ra:)  
Post Last Edited by Ra at 2014-8-12 16:02

For me
exec /usr/bin/lxsession -s Lubuntu -e LXDE instead of . /usr/bin/startlxde
worked perfectly fine (have the same screen for the same user).
And in /etc/xrdp/xrdp.ini was changed line port=ask-1 - to be able to connect the same open session (using port number that can be seen on the login process dialog box, second line).But still have some troubles with logout screen, etc...
123.JPG

Raymond  
Reply 6# Ra

I saw mikronauts' review he guess that might be a bug from Debian.  Debian Bug report logs - #703016

Tonband  
Hi,
this is my way, i had the  same problem:

Open console and install as root on your BPI:
apt-get ...
Rincewind666 Posted at 2014-8-10 02:15


Not working for me! (via ssh as root)
enter vino-preferences ends in an error: cannot open display:

user777  
maxwell replied at Sat Aug 9, 2014 16:29
Post Last Edited by maxwell at 2014-8-9 16:33

Post Last Edited by maxwell at 2014-8-9 16:32

Hi Maxwell
     thank you, works perfect.
I use gtkvncviewer for the master pc running mint 17

You have to log in before you can reply Login | Sign Up

Points Rules