Other OS

[SOLVED] Problem with systemd

10 19982
Fab  
Post Last Edited by Fab at 2014-9-8 07:52

Hi

I use Arch 1.1.1

Inspecting the journal after boot I see the following error:

Jan 01 08:01:31 bananapi systemd[1]: Job dev-ttyS0.device/start timed out.
Jan 01 08:01:31 bananapi systemd[1]: Timed out waiting for device dev-ttyS0.device.
Jan 01 08:01:31 bananapi systemd[1]: Dependency failed for Serial Getty on ttyS0.
Jan 01 08:01:31 bananapi systemd[1]: Job sys-subsystem-net-devices-eth0.device/start timed out.
Jan 01 08:01:31 bananapi systemd[1]: Timed out waiting for device sys-subsystem-net-devices-eth0.device.
Jan 01 08:01:31 bananapi systemd[1]: Dependency failed for Automatic wired network connection using netctl profil

The first in particular seems like a known problem, but I do not understand how the suggested solution works.
http://permalink.gmane.org/gmane ... systemd.devel/16777
http://lists.freedesktop.org/arc ... ebruary/016935.html

Could somebody please help me understand what I need to do? Thanks
A bit of searching reveals the kernel parameter CONFIG_FHANDLE should be set to make the kernel work with systemd ver 209 and above.
so that should be your starting point.
check your systemd version...
extract the running kernel's .config and check if the above parameter is set to "y"
If that is ok then you'll have to look further.

You can even try Arch 2.0 to see if it fixes the issue for you.

Fab  
Post Last Edited by Fab at 2014-8-31 01:17

Joseph,
thanks for your reply. Running systemctl --version I can see that my systemd is version 219, so it would seem that is needed! Looking in /proc/config.gz I can confirm that CONFIG_FHANDLE is not set

Browsing the linux-bananabi latest repo I found the commit copied below by Tony Zhang, which introduces the configuration file arch/arm/configs/sun7i_defconfig and here CONFIG_FHANDLE is not set.

I suppose this means that I need to update sources and recompile everything, correct? Hopefully Tony can put this in the next image.



  1. commit a54172add9287135d55523faf029101cfd0b5087
  2. Author: Tony Zhang <hitxfd.tony@gmail.com>
  3. Date:   Mon Jul 21 23:33:59 2014 +0800
  4.     modified kernel config to suport Banana Pi

  5. diff --git a/arch/arm/configs/sun7i_defconfig b/arch/arm/configs/sun7i_defconfig
  6. index 455ebcc..3b289c5 100644
  7. --- a/arch/arm/configs/sun7i_defconfig
  8. ...
  9. +# CONFIG_FHANDLE is not set
  10. ...
Copy the Code

Fab  
Post Last Edited by Fab at 2014-8-31 02:46

I found the compatibility specifications of systemd at:
http://cgit.freedesktop.org/systemd/systemd/tree/README

I wonder if incorrect kernel settings could also be the cause of the problems I am having with grep and with auto-mounting an external USB hard drive.
http://forum.lemaker.org/3307-1-1-auto_mount_usb_hard_drive_fails.html
http://forum.lemaker.org/3332-1-1-problem_with_grep.html

In particular, in Arch 1.1.1 configuration I see the related configuration flags:

  1. # CONFIG_SYSFS_DEPRECATED is not set
  2. CONFIG_BLK_DEV_BSG=y
Copy the Code

Are they set correctly?

Not sure about the grep but the usb automounting could well be because of systemd not working correctly.
And yes you would have to recompile the kernel with FHANDLE set.

If you have a spare sdcard you could try the Arch2.0 first.

Got it !

Reply 6# tony_zhang

I' m running Arch 2.0 and downgrading systemd to version 215 solved tty and disk mounting issues.

Fab  
Thanks for the tip. If fixing FHANDLE does not work, I will try that.

Fab  
Recompiling the kernel as in instructions:
http://forum.lemaker.org/1837-1- ... _configuration.html
But setting
  1. CONFIG_FHANDLE=y
Copy the Code
solves the problem.

heinzie  
Hi,

I've tried to recompile the kernel by using the instructions mention above, but the following command
make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- uImage modules
throws the following error:
In file included from include/linux/posix_types.h:4:0,
                 from include/linux/types.h:17,
                 from include/linux/page-flags.h:8,
                 from kernel/bounds.c:9:
include/linux/stddef.h:12:3: error: expected identifier before ‘false’
include/linux/stddef.h:12:3: error: expected ‘}’ before ‘false’
include/linux/stddef.h:12:3: error: expected unqualified-id before ‘false’
include/linux/stddef.h:14:1: error: expected declaration before ‘}’ token
make[1]: *** [kernel/bounds.s] Error 1
make: *** [prepare0] Error 2

Seems like something wrong with the header file... Tried to fix this myself, but frankly I am not so good with these things.....

You have to log in before you can reply Login | Sign Up

Points Rules